lupdate

How To Install Lupdate In Debian, Ubuntu, Arch, Kali, Fedora And Raspbian?

How To Install Lupdate In Debian, Ubuntu, Arch, Kali, Fedora And Raspbian?

lupdate

Qt 4 Linguist tools

Maintainer: Debian Qt/KDE Maintainers



Section: libdevel

Install lupdate

  • Debian apt-get install qtchooser Click to copy
  • Ubuntu apt-get install qtchooser Click to copy
  • Arch Linux pacman -S qt5-tools Click to copy
  • Kali Linux apt-get install qtchooser Click to copy
  • Fedora dnf install mingw64-qt5-qttools-tools Click to copy
  • Raspbian apt-get install qt3-dev-tools Click to copy

qt4-linguist-tools

Qt 4 Linguist tools

Qt is a cross-platform C++ application framework. Qt's primary feature is its rich set of widgets that provide standard GUI functionality. This package contains lupdate and lrelease. lupdate is a command line tool that finds the translatable strings in the specified source, header and Qt Designer interface files, and produces or updates .ts translation files. lrelease is a command line tool that produces QM files out of TS files.

qt3-devel

Development files for the Qt 3 GUI toolkit

qttools5-dev-tools

Qt 5 development tools

Qt is a cross-platform C++ application framework. Qt's primary feature is its rich set of widgets that provide standard GUI functionality. This package contains a set of applications to browse the documentation, translate applications, generate help files and other stuff that helps in Qt development. These tools are among others: * assistant * designer * linguist * pixeltool * qdbusviewer

qt-devel-1

4.8.7-44.fc30.x86_64 : Development files for the Qt toolkit

qtchooser

Wrapper to select between Qt development binary versions

Qt is a cross-platform C++ application framework. Qt's primary feature is its rich set of widgets that provide standard GUI functionality. The Qt Chooser provides a wrapper to switch between versions of Qt development binaries when multiple versions like 4 and 5 are installed or local Qt builds are to be used. If you wish to use Qt development binaries with the default PATH and without special parameters, you need to additionally install either qt4-default or qt5-default package to provide the default configuration.

qt5-linguist

Qt5 Linguist Tools

mingw32-qt5-qttools-tools

component

mingw64-qt5-qttools-tools

component

qt4

A cross-platform application and UI framework

qt5-tools

A cross-platform application and UI framework (Development Tools, QtHelp)

qt3-dev-tools

Qt3 development tools

This package contains all tools that are necessary to build programs that are written using Qt3. These are: qmake, uic and moc. For Qt3 development, you most likely want to install this package.

To install the latest version of lupdate in your favorite operating system just copy the lupdate installation command from above and paste it into terminal. It will download and install the latest version of lupdate 2023 package in your OS.